Traversing the Etherchannel



Ever needed to increase the speed between two switches or devices but you are already physically maxing out the ports throughput? Never fear, Etherchannel is here!

The idea of  joining two physical connections together into one ‘virtual’ group is now possible! Etherchannel allows expansion can liberate bottlenecks.

Won’t spanning tree block my links?

Glad you asked. No it doesn’t as spanning-tree sees it as one link. If a link inside the etherchannel goes down there are other links that continue to function. Etherchannel offers higher bandwidth with less expensive links.

PAgP and LACP – Etherchannel Cisco’s way or IEEE’s way

PAgP – Aids in the automatic creation of ether channel links. PAgP packets are sent between ports and negotiate the forming of a channel. STP adds the channel as a single bridge port.

PAgP packets are sent every 30 seconds or so. These packets check for configuration consistency and manages links between two switches.

The dynamic modes are as follows:

  • Auto – Passive negotiating state. Does not initiate.
  • Desirable – Active negotiating state. Initiates by sending PaGP packets.
  • On – Forces to channel without PAgP. Does not exchange PaGP.
  • Non-silent – used with auto/desirable. Used for file-servers or packet analyzers.
Channel will form with these configurations
  • On > Channel < On
  • On/Auto/Desirable > No Channel < Off
  • Auto/Desirable > Channel < Desirable
  • Auto/On > No Channel < Auto


LACP – IEEE 802.3ad that enables physical ports to be bundled together. LACP sends packets like PAgP does to dynamically form channels with peers. Works in a mixed environment.

LACP Modes are similar to PAgP but are to the IEEE standard.

  • Passive – Responds to LACP packets but doesn’t initiate negotiation
  • Active – Initiates negotiations with other switches.
  • On – Forces interface to channel with PAgP or LACP
LACP Channel configs
  • On > Channel < On
  • On/Active/Passive > No Channel < Off
  • Active/Passive > Channel < Active
  • Passive/On > No Channel < Passive
Pre-Flight Checks to surfing the Channel
Etherchannel Suff
Surfing the Ether
Identify where you will place the etherchannel. Ensure switchports at both ends have clear switchport configurations. Determine your requirements such as L2/L3 and PAgP/LACP. Remember a maximum of 8 ports per etherchannel and all ports need to have the same speed and duplex settings. Interfaces cannot be SPAN ports. If you use a L3 channel, remember that IP addresses are set to the port-channel. Native VLAN’s must match. The allowed VLAN’s must match too.
Configuring and catching frames/packets on the ether
interface Port-channel9
 description WLC-5508 PORT CHANNEL
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate

interface GigabitEthernet1/0/21
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 ip arp inspection trust
 mls qos trust cos
 no cdp enable
 channel-group 9 mode on
 spanning-tree portfast trunk
 ip dhcp snooping trust
interface GigabitEthernet1/0/22
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 ip arp inspection trust
 mls qos trust cos
 no cdp enable
 channel-group 9 mode on
 spanning-tree portfast trunk
 ip dhcp snooping trust

Above is an example of a port channel configuration. Although this one goes to a 5508 WLC aslong as the configurations match each side and the correct ports are in their channel-group, we have a channel formed.

switch#show etherchannel summ
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

Number of channel-groups in use: 9
Number of aggregators:           9

Group  Port-channel  Protocol    Ports
<<!! Excluded for brevity !!>>
9      Po9(SU)          -        Gi1/0/21(P) Gi1/0/22(P)
                                 Gi1/0/23(P) Gi1/0/24(P)

Here I have verified the status of my port channel and confirmed what ports are in the channel and the mode it is in include the state.

switch#show etherchannel 9 port-channel
                Port-channels in the group:

Port-channel: Po9

Age of the Port-channel   = 09d:04h:55m:26s
Logical slot/port   = 10/9          Number of ports = 4
GC                  = 0x00000000    HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =    -

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
  0     00     Gi1/0/21 On/FEC             0
  0     00     Gi1/0/22 On/FEC             0
  0     00     Gi1/0/23 On/FEC             0
  0     00     Gi1/0/24 On/FEC             0

Time since last port bundled:    09d:02h:58m:12s    Gi1/0/24
Time since last port Un-bundled: 09d:02h:58m:13s    Gi1/0/24

Here is another show command. This one focuses on the particular channel. It allows me to see all sorts of information such as number of ports, up time and more.

Whoa dude. So much on my ether channel I am loosing balance.

Now you have made this bandwidth rich connection you might think jobs done. Well there is a lot more you can do. Balancing out your etherchannel can vastly improve it’s performance.

Default for 2960, 3560 and the 3750 platform is src-mac, where as 4550 and 6500 series default to src-dst-ip.

  • src-mac
  • dst-mac
  • src-dst-mac
  • src-ip
  • dst-ip
  • src-dst-ip
  • src-port
  • dst-port
  • src-dst-port
These are the types of load balancing you can perform. Due to the fact that the load balancing applies to all channel groups on that switch chassis you need to consider the outcome.
switch(config)# port-channel load-balance src-ip

switch# show etherchannel load-balance
Etherchannel Load-Balancing Configuration:

This configuration will make all port channels on this switch load balance based upon the source ip address. Rather handy!


Leave a Reply

Your email address will not be published. Required fields are marked *