CCIE Study: EIGRP interface types

I have come across some interesting behaviour at the interface level with EIGRP.

Dynamic

By default many people use the network command to form a neighbor with EIGRP. This involves sending Hellos to 224.0.0.10 or FE02::A at the default interval of 5 seconds. This will send it out of any interfaces with the IP address range designated by the network statement. In our case this is 155.1.0.0/24.

In classic mode the config looks like this:

router eigrp 45
network 155.1.0.0 0.0.0.255

The named mode configuration would look like this:

router eigrp PANDOM-EIGRP
!
address-family ipv4 unicast autonomous-system 45
!
topology base
exit-af-topology
network 155.1.0.0 0.0.0.255
exit-address-family

Static

If you’re asked to use a non multicast method of forming a neighbor then defining a neighbor 155.1.0.4 Tunnel 0 command would do this. This would send a unicast version of all messages to the defined neighbor only to form a relationship.

In classic mode the config looks like this:

router eigrp 45
neighbor 155.1.0.4 Tunnel 0
neighbor 155.1.0.3 Tunnel 0

The named mode configuration would look like this:

router eigrp PANDOM-EIGRP
!
address-family ipv4 unicast autonomous-system 45
!
topology base
exit-af-topology
neighbor 155.1.0.4 Tunnel 0
neighbor 155.1.0.3 Tunnel 0
exit-address-family

What happens if I want to use both?

If I choose to add the network command to either the Classic mode or Named mode configuration (bearing in mind that its purely a syntax thing) I would append network 155.1.0.0 0.0.0.255 to either the classic instance or the address family.

Doing this will have some interesting results. The configuration should statically configure and unicast neighbors 3 and 4 whilst the network command should multicast neighbors 1 and 2.

Only my static neighbors are appearing in a show ip eigrp neighbor command.

R5#show eigrp address-family ipv4 45 neighbors
EIGRP-IPv4 VR(PANDOM-EIGRP) Address-Family Neighbors for AS(45)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 155.1.0.4 Tu0 12 00:00:45 8 1258 0 5
1 155.1.0.3 Tu0 12 00:00:21 8 1258 0 5

Lets have a look at the debug to find out why.

EIGRP: Received HELLO on Tu0 - paklen 20 nbr 155.1.0.4
AS 50, Flags 0x0:(NULL), Seq 0/0 interfaceQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
EIGRP: Received HELLO on Tu0 - paklen 20 nbr 155.1.0.3
AS 50, Flags 0x0:(NULL), Seq 0/0 interfaceQ 0/0 un/rely 0/0 peerQ un/rely 0/0
EIGRP: Received HELLO on Tu0 - paklen 20 nbr 155.1.0.1
AS 50, Flags 0x0:(NULL), Seq 0/0 interfaceQ 0/0
EIGRP: Ignore multicast Hello Tu0 155.1.0.1
EIGRP: Received HELLO on Tu0 - paklen 20 nbr 155.1.0.2
AS 50, Flags 0x0:(NULL), Seq 0/0 interfaceQ 0/0
EIGRP: Ignore multicast Hello Tu0 155.1.0.2

Note that the Multicasts Hello from R1 and R2 are being ignored on the Tunnel 0 interface of R5 where we did our config.

What interface type to choose?

Depending on your environment and the way you build your network you will control how your advertise your neighbors. On a point to multipoint segment with a common subnet it is more likely a dynamic method that leverages multicast will be used. I came across using static neighbors as a part of my CCIE study and it took me a little bit to find out why my neighbors wouldn’t stay up when configuring a unicast neighbor. I now know IOS ignores multicast updates when unicast neighbors are configured.

 

4 thoughts on “CCIE Study: EIGRP interface types

  1. Fred Ferrell says:

    Isn’t multicast used just for the neighbor relationship? And once the neighbor is discovered, they use unicast to communicate hello packets between each other?

    BTW, I look forward to reading about your goal towards CCIE. I plan to finish my CCNP shortly and move into the CCIE myself. This will be a great blog to follow for the new version.

    • Here is a two router setup with a simple fa0/0 interface to other on the 192.168.1.0/24 network.

      Commands are

      router eigrp 1
      neighbor 192.168.1.2
      network 192.168.1.0
      no au

      Here is an example hello packet.
      104 36965.240515000 192.168.1.1 192.168.1.2 EIGRP 74 Hello
      105 36968.654034000 192.168.1.2 192.168.1.1 EIGRP 74 Hello

      Definitely unicast. 🙂 Good luck with the CCNP and the studies. Thanks for the sport and readership.

    • pandom says:

      Here is a two router setup with a simple fa0/0 interface to other on the 192.168.1.0/24 network.

      Commands are

      router eigrp 1
      neighbor 192.168.1.2
      network 192.168.1.0
      no au

      Here is an example hello packet.
      104 36965.240515000 192.168.1.1 192.168.1.2 EIGRP 74 Hello
      105 36968.654034000 192.168.1.2 192.168.1.1 EIGRP 74 Hello

      Definitely unicast. 🙂 Good luck with the CCNP and the studies. Thanks for the sport and readership.

  2. Marr17 says:

    I came across this issue while using INE v5 CCIE R&S Advanced Techonologies Course . The study material would not coincide with the output of the router.

Leave a Reply

Your email address will not be published. Required fields are marked *

*